AirWare
air quality assessment & management
Reference and User Manual
AirWare   On-line Reference Manual
  Release Level 7.0
  Revision Level beta
  Release Date 2015 03

Last modified on:   Tuesday, 14-Jul-15 18:52 CEST

DEM as background map

Due to their global coverage at high resolution, DEM data are used as the default background map for many model domains.

  1. GET DATA:

    • Goto http://earthexplorer.usgs.gov/
    • select coordinates, and 'DEM'
    • Download the corresponding geotiff files.

  2. QGIS:
    • Open all the *tif files: "Layer" -> "Add raster layer" and select tif files
    • Merge the files: Raster->Miscellaneous->Build Virtual raster
    • Transform lat-lon to UTM: Project -> Project properties enable on the fly CRS transformation, select, e.g., "WGS 84/UTM zone 36N"
    • in case the layer panel is not open: View -> Panels -> Layers
    • Save: right click on the (merged) layer, "save as" *.tif select UTM projection and extent and resolution

  3. tif to asci
    • gdal_translate -of AAIGrid *tif outfile.asc

  4. asci to matrix and to binary INT file:
    • server:/app/air/tools/importHWSD/bin/lnx64/importDEM.cgi
      (substitute the apporpriate path to the local tools directory)
      Usage: importDEM.cgi [-?] [-f|--db-config=STRING] [-i|--domain-id=INT]
              [-r|--resolution=INT] [-p|--file-path=STRING]
              [-d|--descriptor=STRING]
              [-n|--matrix-name=STRING] [-?|--help] [--usage]
      
      The domain given by domain-id has to have the same dimensions as the *asc file! importDEM.cgi imports the data as a matrix and generates "out.dem" (=binary INT file) file in the working directory

© Copyright 1995-2016 by:   ESS   Environmental Software and Services GmbH AUSTRIA | print page